Šta je novo?
SerbianForum

This is a sample guest message. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

  • Hvala svima na 1 900 000+ postova & 500 000+ tema!

Otključavanje WinCe uređaja i instaliranje iGO navigacije

  • Začetnik teme kopca
  • Datum pokretanja
T

theshrink89

Kao prvo, pozdrav svima. :)
E sad, da predjemo na problem. Imam kod sebe Mio Moov 330 koji nikad nije čačkan, tastova navigacija. Ponesoh je sad na Lefkadu za svaki slučaj i danas mi posle par fotki crkne moj dragi mobilni telefon koji me je i doveo do ovde. E sad, najveća muka je što su na ovom čudu mape iz 2009. godine i kad potražim rutu za nazad do Niša, on mi nadje neku šesnaestu putem koje trebam da predjem celih 1200 kilometra što je debilizam, u dolasku sam prešao 780 :gl_wacko:
Bacih se na pretragu i vidim da mogu da roknem iGO u ovog Mia, i tu kreću moje muke. Našao sam varijantu za ubacivanje (modifikujem autorun fajl iz samog MioMap - a da umesto njega pokreće navigaciju koju sam ja ubacio) ali tu nailazim na sledeću blokadu. Pošto sam pročitao da igo primo hoće da baguje pošto imam 64mb rama rešim da ubacim igo8. Sve ja iskopiram na internu memoriju (mmc u navigaciji je celih 128mb a interna 1gb tako da sam od kartice odmah odustao), odredim putanju za exe fajl, upalim navi i ona mi kaže da ne moze da pronadje bazu podataka. Pokušam u sys.txt da podesim nekako putanju da je navi uhvati ali apsolutno bezuspešno i ne mogu da provalim gde grešim. Na kraju dignem ruke i probam da ubacim Primo 2.0 i kad njega probam da pokrenem, onda mi pa izbaci "global_cfg not found". Proverim u content kad ono fajl tamo! Sad sam već totalno zbunjen, ubacivao sam iGO u androida nebrojano puta i nikada nisam imao muku al ovaj glupi mio mi dušu uze više! Pomagajte ljudi, šta da mu radim i kako da ga rešim da radi i da me vrati kući?
koristio sam ovaj tutorijal za obilaženje MioMap - a i direktno pokretanje iGO bez potrebe instalacije dodatnih softvera, pokretača itd

Hvala unapred!
 
Bocky72

Bocky72

Član
Loše su ti putanje u sys fajlu kod tih iGO-a koje si koristio.
Za ostalo, trebaju mi baba Vanga, kristalna kugla, karte i pasulj da potrefim šta si uradio i kako.
Bolje je da si koristio SD karticu, unlock sa nje i sve ostalo. Imaš na prvoj strani sve potrebno.
Primo 2.0 lepo funkcioniše na tom Mio-u.
 
T

theshrink89

Evo probao sam i da je otključam sa shellom, vratio sam sve u normalu, iskopirao sam sadržaj kopcashell foldera na root kartice, resetovao navigaciju i opet ništa, pokreće MioMap... Samo mi je memorijsku preimenovao u Becker Content Manager...

Da ne bi tražio sad kristalnu kuglu, mogu da ti opišem šta sam radio :)
-Prvo sam skinuo odavde ovaj iGO primo 2.0 KIA jer za njega radi link.
-iskopirao sam ga u Program Files na internoj memoriji (Program Files/Primo Kia)
-ušao u folder MioMap, notepadom otvorio AutoStartupSec.ini i u njemu promenio stringove:
RelativePath=TRUE u FALSE
ProcessFile=/Program Files/MioMap/MioMap.exe i ovde zadao putanju za Primo.
putanja je posle edita izgledala ovako:
ProcessFile=/Program Files/Primo Kia/MobileNavigator.exe

kada sam pokrenuo navigaciju, tražila mi je global_cfg. Stvarno ga nije bilo u folderu pa sam ovde sa foruma skinuo global_cfg i iskopirao ga gde treba ali on i dalje traži global_cfg i neće... :gl_sigh:
 
Poslednja izmena:
Bocky72

Bocky72

Član
Mislim da folder ne sme da ima razmak u imenu. Dakle, samo Primo. Izvršni exe isto imenovan.
I obriši save folder, ceo.

Pa kada ubaciš šell na karticu, treba da ubaciš i navigacione softvere na nju, poštujući nomenklaturu koja je već prisutna. Najprostije.
 
T

theshrink89

Evo pokušao sam sad da izvadim folder sa navigacijom u root interne memorije, preimenovao folder i exe fajl i prepravio string ali i dalje global_cfg not found.
evo kako mi izgleda sys.txt:

[device]
type="MIO_MOOV"
[gps]
port="auto"
baud="auto"
;set_messages=0
[rawdisplay]
class="landscape"
highres=0
screen_x="auto"
screen_y="auto"
[debug]
experimental_features=0
skip_eula=1
[folders]
has_secondary_root=0
[http]
enabled=0
[interface]
maxzoom2d=6000000
show_exit=1
;resolution_dir="800_480"
extra_settings=0
capture_to_jpeg=0
laneinfo_signpost_enabled=1
[map_update_checker]
enabled=0
[network]
available=0
[other]
demo_enabled=0
[power]
backlight_tunnel_default=50
backlight_sync_with_os=0
powermgm_state=0
tunnel_backlight_enabled=1
[sound]
ding=0
;ding_muted=1
mute_os_key=1
pause_mp3_sooner=1
csv_voice_enabled=1
[warning]
speedcam_warning=1
speedcam_soundtype=2
send_warn_event=1
is_spoken=1

Stvarno više nisam pametan...
Uklanjao sam i string vezan za folders, ništa... Izbacio sam i ceo sys fajl iz foldera, opet ništa... Uporno traži global_cfg
 
Poslednja izmena:
Samo malo brzas, skoncentrisi se na glavno a to su putanje, naveo si da ti je putanja poslije edita izgleda ovako:
ProcessFile=/Program Files/Primo Kia/MobileNavigator.exe

Zasto?
Nadam se da ti je i u PrimoKia folderu exe fajl MobileNavigator.exe
 
T

theshrink89

Baš tako, u Primo Kia folderu exe fajl je nosio ime MobileNavigator, zato sam i stavio takav path... Sada sam izvukao folder navigacije na root interne i onda sam i folder i exe fajl preimenovao u Primo, naravno adekvatno prepodesio path da bi našao i pokretao taj exe fajl ali opet zid na kome piše "global_cfg not found". Po svemu sudeći on je ukapirao sam exe fajl i pokuša da ga pokrene ali onda sam iGo ne može da pronadje global_cfg... Da ne postoji neka greška u sys.txt fajlu? probao sam tri različita global_cfg fajla i neće...
 
Ne znam samo odakle si skinuo taj Kia, jer u njemu nije nazvan MobileNavigator.exe a i sys je malo različit.
Pa bi red bio da skineš sa prve strane pa da znamo šta je...
I valjda je rezolucija 480x272 tog Mio moov-a

Probaj prvo vizual shell na karticu koji radi za moov sa 480x272:
You need to like this in order to view this content.
i nije do global config. sigurno, to džaba mijenjaš...
pa ćemo dalje, uglavnom vratićemo te kući :)
 
T

theshrink89

Evo skidam Kia sa prve strane, e sad imam tu mali problem, ne kapiram baš najbolje kako da upotrebim ovaj tvoj shell... :oopss:

I vrlo bitna stvar, u ovom čudu je sd od samo 128 megabajta guljavih... Tako da bi bilo super kad bi nekako mogli da se orijentišemo na internu memoriju...:)

EDIT:
Evo probah i Kia sa prve strane, opet ista priča...
 
Poslednja izmena:
I ubijeđen sam da ti je putanja u redu čim ti izbacuje global... ali nešto nije u redu sa Primom ili sys.txt
Ako se sa PrimoKia dogodi isto potrebno je dodati:

[folders]
app="My Flash Disk/PrimoKia" ;ako ti se tako zove, ako je direktno na My Flash Disk
content="My Flash Disk\PrimoKia\content"
map="Storage Card\Addons\content/map" ;ovo je ako hoćeš dodatne mape na kartici
kmlpoi="userdata\poi" ;"content\poi"
kmlroute="userdata\route" ;"content\userdata\route"
has_secondary_root=0 ;1 ako hoćeš te dodatne mape

i mozda zamijeniti i ovo zbog bržeg nalaženja signala i podešavanja osvjetljenja:
[gps]
port=2
baud=57600

[power]
backlight_manage_values = 1
backlight_manage_keys = 1
backlight_max = 100
backlight_min = 0
backlight_reverse = 0
backlight_methods = 39
backlight_events = 1
battery_warning_limit=20
battery_warning_repetition=1
skip_resume_process=1
skip_suspend_process=1
powermgm_state=0


A zadnje pitanje:
Kada vidiš (sa 7zip otvarati) folder default i MobileNavigator, njih staviti na karticu i resetovati, to je samo proba ne znači da će raditi...

EDIT:
Pa i govorim da treba na internu (My Flash Disk)
 
Poslednja izmena:

Top